HERE Android SDK Developer's Guide

System Requirements

HERE Android SDK is designed and tested with Android phones and tablets in mind. SDK performance will vary between devices, since it is primarily determined by CPU, GPU, and display resolution. Currently, Nexus 5 is a suitable reference for a device which delivers acceptable SDK performance. If your target device is not a phone or tablet, see Service Support to contact us for more details .

  • Android 4.1.x "Jelly Bean" (API Level 16) or higher as the application Minimum API Level (android:minSdkVersion)
  • Apps should be developed using Android Studio 2.3.2 or above
  • 32MB of memory (RAM) available for foreground applications
  • A minimum of 1MB per application should be made available for storing HERE SDK libraries
  • A minimum of 3.5MB should be made available for storing map data
  • Data connectivity (Wi-Fi or Cellular) is required to download map data
Note: HERE Android SDK does not support x86 Android and x86_64 devices. x86 and x86_64 emulators are supported. It is recommended that app testing is performed on ARM and ARM64 devices.