Versioning Scheme

The Data Client Base Library uses the semantic versioning scheme 2.0.0.

Binary Compatibility

The Data Client Base Library maintains backwards binary compatibility across versions of its modules.

  • Binary compatibility is maintained between minor and patch versions
  • Binary compatibility is NOT maintained between: major versions

If you use it with other libraries from the HERE platform SDK please make sure that you use all libraries from the same SDK version.

Mixing Module Versions is Not Allowed

Modules that are released together under the Data Client Base Library are intended to be upgraded together.

This is because modules may have changed internally. For example, a feature in one module may have required changes internally in another module. However, these changes are not part of the public API, so binary compatibility is still maintained.

results matching ""

    No results matching ""